Contents

 Modulus Financial Engineering Home Modulus Financial Engineering
 StockTicker ActiveX

Software Requirements

Personal computer with Pentium 1500-megahertz (MHz) or higher CPU, 256 MB of RAMl, VGA or higher resolution monitor; Super VGA recommended, Microsoft Windows 98, Windows 98 Second Edition, Windows Millennium Edition (Windows Me), Windows NT 4.0 with Service Pack 6 (SP6),1 Windows 2000, or Windows XP or later.

Contents

Programming with the StockTicker ActiveX Control

End User License Agreement

Technical Support

Copyright © 2005 Modulus Financial Engineering, Inc.


Contents

The StockTicker ActiveX Control

The StockTicker control is a lightweight ActiveX for displaying delayed NYSE, NASDAQ, and AMEX stock prices.

This control is similar to the CNBC television Stock Ticker that runs Monday-Friday, 9:30AM-4:00PM (ET).

Four example projects are included with the StockTicker installation (VB6, VC++, C#, and VB.NET).

Contents

Adding and Editing Symbols, Prices, and Volume

Enumerating All Symbols and Values

Removing Symbols from the Ticker

Setting the Speed of the Ticker

Setting the Scroll Quality of the Ticker

Setting the Background Color for the Top (NYSE) Band

Setting the Background Color for the Bottom (NASDAQ/AMEX) Band

The Gradient Background Painting Property

Allowing the User to Grab and Move the Ticker


void AddEditSymbol(BSTR Symbol, double Price, long Volume, double Change, ExchangeType Exchange)

The AddEditSymbol function will add a new symbol to the ticker. The symbol will be adjusted if it already exists on the ticker.

To place the symbol in the top banner pass NYSE in the Exchange argument, otherwise pass NASDAQ or AMEX to make the symbol appear in the bottom banner.

Note

The UpdateTicker function must be called before your updates will appear in the ticker.

See Also

RemoveSymbol, UpdateTicker, ExchangeType


void RemoveSymbol(BSTR Symbol, ExchangeType Exchange)

The RemoveSymbol function removes a symbol from the ticker that has previously been added via the AddEditFunction.

Note

The UpdateTicker function must be called before your updates will appear in the ticker.

See Also

AddEditSymbol, UpdateTicker, ExchangeType


void UpdateTicker()

The UpdateTicker function must be called before any updates made via the AddEditSymbol or RemoveSymbol functions will appear on the stock ticker.

Note

The UpdateTicker function is processor intensive and should be called only after several updates have been made or only once every few seconds at maximum.

See Also

AddEditSymbol, RemoveSymbol


void ListSymbols()

The ListSymbols function causes the StockTicker ActiveX to enumerate all symbols that have previously been added via the AddEditSymbol function.

The ListSymbol event will fire once for each symbol.

Note

The UpdateTicker function must be called before your updates will appear in the ticker.

See Also

ListSymbol Event, AddEditSymbol, RemoveSymbol, ExchangeType


short Speed

The Speed property instructions the StockTicker ActiveX to stop, speed up, or slow down the stock ticker.

1 = fastest, 2 thru 100 are slower, and if set to zero (0) the ticker will stop.

See Also

PixelsToScroll


short PixelsToScroll

The PixelsToScroll property instruction the StockTicker ActiveX to skip over n-pixels during each update. The default value is 1 for smooth scrolling. If set to 2 or more the ticker will seem to scroll faster. This property can be used in conjunction with the Speed property for machines where CPU power and graphics capabilities are less than optimal.

1 = default, 2 thru 100 are faster but less smooth.

See Also

Speed


boolean AllowGrabbing

If set to TRUE this property will allow the user to grab the stock ticker using a hand mouse pointer and move it forwards and backwards. The default arrow pointer will be displayed if set to FALSE.


OLECOLOR NYSEBackColor

Sets or retrieves the background color of the top (NYSE) band.

See Also

NASDAQBackColor, UseGradients


OLECOLOR NASDAQBackColor

Sets or retrieves the background color of the bottom (NASDAQ) band.

See Also

NYSEBackColor


boolean UseGradients

By default the StockTicker's NYSE (top) band uses a gradient from NYSEBackColor to white, and back. Gradients will not be used if this property is set to FALSE.

See Also

NYSEBackColor


enum ExchangeType
{
NYSE,
NASDAQ,
AMEX
}

Specifies the exchange, where NYSE references the top banner and NASDAQ and AMEX reference the bottom banner.

See Also

AddEditSymbol, RemoveSymbol, UpdateTicker


License Agreement

LICENSE AGREEMENT

The following license agreement governs your use of Modulus Financial Engineering products. Please read this agreement carefully before using the software.

THIS LICENSE AGREEMENT (the "Agreement") is entered by and between Modulus Financial Engineering (herein referred to as "MFE") and the Receiving Party (you).

1. TERMS AND CONDITIONS

BY COPYING OR OTHERWISE USING MFA SOURCE CODE FILES OR COMPONENTS, YOU AGREE TO BE BOUND BY ALL OF THE TERMS AND CONDITIONS OF THIS LICENSE AGREEMENT. Upon your acceptance of the terms and conditions of the License Agreement, you are granted the use of the source code or component in the manner provided below. The source code is the intellectual property of MFA and is protected by copyright law and international copyright treaty. Therefore, you must use this source code like any copyrighted material (such as copyrighted music, art, or books). Except as provided in the License Agreement, you may not transfer, rent, lease, lend, modify, translate, sublicense, time-share or electronically transmit or receive the source code, media or documentation.

2. USAGE AND REDISTRIBUTION

YOU MAY NOT, UNDER ANY CIRCUMSTANCE, REDISTRIBUTE THE SOURCE CODE, THE .LIC LICENSE FILE OR IN ANY WAY LICENSE THE PRODUCT FOR THE DEVELOPMENT ENVIRONMENT ON MORE THAN ONE MACHINE!

AGAIN: YOU MAY *NOT* REDISTRIBUTE THE .LIC LICENSE FILE OR SOURCE CODE. CIVIL AND/OR CRIMINAL PENALTIES WILL BE ENFORCED.

You may include the source in COMPILED form (*.exe, *.dll, *.ocx, *.so, *.jar and *.class files). You may not distribute image files of the output from any of our products via the Internet or by means of any other network. To do so, you must acquire a separate ENTERPRISE license from MFE. If you own a license to the product's source code, you may modify the source code to adapt it to your needs, however you may only redistribute the compiled form of the modified source code. You are not allowed to redistribute any original or modified source code file. You are not allowed to copy and paste source code into external classes. All source code is copyrighted and may only be used within the original classes!

You may not resell, rent, lease or distribute the source code OR compiled components alone, they must be distributed as a component of an application and bundled with an application or with the application's installation files. You may not call the source code or compiled components from a scripting language or wrap the component using a wrapper object (for this purpose, to "wrap" or use a "wrapper" means that in which an object is wrapped in other code as an interface between the caller, the MFE product, and the wrapped code) You may not resell, rent, lease or distribute the source code or components in any way that would directly compete with MFE. All source code provided by MFE that is distributed with an application must be compiled or password protected to the extent that only the licensed software developer(s) may obtain access to it. Reverse engineering, reverse compiling, or disassembly of the Software is expressly prohibited.

3. DEVELOPMENT ENVIRONMENT

The development environment requires one (1) license per developer, and at least one license per client, company, or distributor. You may not use the MFE source code or MFE components for consulting purposes. Additional developer and client licenses may be purchased at a discount from MFE. Contact sales@modulusfe.com for details.

4. NON-COMPETE

You shall not own, manage, operate, consult or be employed in a business substantially similar to, or competitive with the present business of MFE or such other business activity in which MFE may substantially engage during the term of this agreement.

5. TRADE SECRETS

You acknowledge and agree that the structure, sequence and organization of the source code contains valuable trade secrets of MFE. You agree to hold such trade secrets in confidence.

6. INTELLECTUAL PROPERTY

The software, including without limitation all design, text, images, white papers, press releases, and other information, is protected under United States and international copyright laws and is owned by MFE or used under license from the copyright owner. The information may not, except under written license from MFE, be copied, reproduced, transmitted, displayed, performed, distributed, rented, sublicensed, altered, stored for subsequent use or otherwise used in whole or in part in any manner without MFE's prior written consent, except to the extent that such use is authorized under the United States copyright laws. MFE trademarks, logos, images, and service marks used in the software are the property of MFE and may not be used without permission from MFE and then only with proper acknowledgment.

7. NO REPRESENTATIONS OR WARRANTIES

MFE assumes no responsibility for, and makes no representations with respect to, the accuracy of the software. Therefore, all data displayed by MFE products are presented "AS IS" and MFE EXPRESSLY DISCLAIMS ANY IMPLIED OR EXPRESS WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT OF INTELLECTUAL PROPERTY RELATING TO SUCH MATERIAL. IN NO EVENT SHALL MFE BE LIABLE FOR ANY DAMAGES WHATSOEVER, INCLUDING WITHOUT LIMITATION SPECIAL, INDIRECT, CONSEQUENTIAL, OR INCIDENTAL DAMAGES, INCLUDING WITHOUT LIMITATION, DAMAGES RESULTING FROM THE USE OF, OR RELIANCE ON, THE INFORMATION PRESENTED, OR LOSS OF PROFITS OR REVENUES. THE SOURCE CODE AND DOCUMENTATION ARE PROVIDED "AS IS". MFE MAKES NO REPRESENTATIONS OR WARRANTIES THAT THE SOURCE CODE, SOFTWARE AND DOCUMENTATION PROVIDED ARE FREE OF ERRORS OR VIRUSES OR THAT THE SOFTWARE AND DOCUMENTATION ARE SUITABLE FOR YOUR INTENDED USE. LIMITATION OF LIABILITY: IN NO EVENT SHALL MFE OR ITS SUPPLIERS BE LIABLE TO YOU OR ANY OTHER PARTY FOR ANY INCIDENTAL, SPECIAL OR CONSEQUENTIAL DAMAGES, LOSS OF DATA OR DATA BEING RENDERED INACCURATE, LOSS OF PROFITS OR REVENUE, OR INTERRUPTION OF BUSINESS IN ANY WAY ARISING OUT OF OR RELATED TO THE USE OR INABILITY TO USE THE SOFTWARE AND/OR DOCUMENTATION, REGARDLESS OF THE FORM OF ACTION, WHETHER IN CONTRACT, TORT (INCLUDING NEGLIGENCE), STRICT PRODUCT LIABILITY OR OTHERWISE, EVEN IF ANY REPRESENTATIVE OF MFE OR ITS SUPPLIERS HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. THIS DISCLAIMER OF LIABILITY FOR DAMAGES WILL NOT BE AFFECTED BY ANY FAILURE OF THE SOLE AND EXCLUSIVE REMEDIES HEREUNDER.

8. GOVERNING LAW

The internal laws of the State of Arizona, without reference to any choice of law provisions, shall govern any claims relating to MFE. MFE may: (a) revise the terms and conditions of this Agreement; (b) revise its license billing rates and surcharges; and (c) modify the services provided under this Agreement at any time. Any such revisions and modifications shall be binding and effective immediately on posting the revised Agreement on MFE's home page, or on notification to you by e-mail or United States mail.

9. TERM OF AGREEMENT

This Agreement shall be binding and effective immediately, and continue until you cease to use the software and all copies or original software are completely destroyed, unless otherwise specifically provided herein.

10. LICENSE TERMINATION

If MFE determines that you are in violation of this Agreement, any restriction or termination of your license will be effective immediately, without prior notice. You agree that MFE will have no liability to you for any restriction or termination of your license or refund of monies paid for the license pursuant to such violation. YOU AGREE THAT IF MFE TERMINATES YOUR LICENSE AS A RESULT OF YOUR VIOLATION OF THIS AGREEMENT, YOU FORFEIT ANY RIGHT TO A REFUND OF ANY LICENSE CHARGES, SUCH FORFEITURE BEING AGREED TO BY YOU AND MFE AS LIQUIDATED DAMAGES AND NOT AS A PENALTY.


Technical Support

Technical Support

You can find answers to your questions using our online support knowledge base at http://www.modulusfe.com/support/kb.asp

You may contact technical support by sending an email to support@modulusfe.com

If your support question is urgent or more consulting-oriented, you can use our Pay-Per-Incident service. A fee in the amount of $99 will be billed to your VISA, MasterCard, Discover or American Express card. Simply call toll free from the U.S. or Canada, 24 hours a day, seven days a week, including most holidays: (888) 318-3754 - press option 3 for Technical Support. Our consulting service is also available from the Live Help menu on our web site.

Consulting

The Modulus FE Consulting Services Group helps Modulus FE customers achieve their strategic financial software development goals. If your company needs additional resources to work with your team, we can assist you. Our Custom Services typically involve a wide, ongoing partnership with Modulus FE customers. We work together to identify and apply technology solutions to specific financial software engineering needs. Our elite team of technology professionals can supplement your internal software developer staff or you can choose to outsource specific design or development tasks to us. Contact the Modulus FE Consulting Services Group for more information.

Copyright © 2005 Modulus Financial Engineering, Inc. All Rights Reserved. http://www.modulusfe.com


event ListSymbol(BSTR Symbol, double Price, long Volume, double Change, ExchangeType Exchange)

After calling the ListSymbols function this event will fire once for each symbol that has previously been added via the AddEditSymbol function.

See Also

ListSymbols, AddEditSymbol, RemoveSymbol, ExchangeType